Ride with GPS supports the following browsers:

  • Chrome – most recent or second most recent version
  • Safari – most recent or second most recent version
  • Firefox – most recent version only
  • Internet Explorer (IE) 11
  • Edge – most recent version only

Want to find out what browser you are using? You can use the website http://whatbrowser.org/.

Browsers other than those listed may work with Ride with GPS, but functionality may degrade over time as we update our website. We will do our best to provide customer support for unsupported browsers, but unfortunately, we cannot guarantee functionality. For the best experience, we recommend using a supported browser.


Facebooktwitterredditpinterestby feather